WordPress › PHP 4 and MySQL 4 End of Life Announcement:

For WordPress 3.2, due in the first half of 2011, we will be raising the minimum required PHP version to 5.2.

we are also going to be dropping support for MySQL 4 after WordPress 3.1. Fewer than 6 percent of WordPress users are running MySQL 4. The new required MySQL version for WordPress 3.2 will be 5.0.15.

Давно пора было уже.
Полагаю, что количество кода должно сократиться в полтора раза, минимум.